
The Bubble Mask Instructable 

By Leandro Rolon 

 

See the attached link for more sketchup tutorials  

 

http://www.sketchup.com/learn/videos?playlist=58 

 

 

Step 1: Download and Install Sketchup Make 2015. Its free! 

 

 

 

 

http://www.sketchup.com/learn/videos?playlist=58


Step 2: Download and Install Shape Bender Extension from  

https://extensions.sketchup.com/en/content/clf-shape-bender 

 

 

 

Open sketchup and Follow install instructions. For this model we will me 

using the millimeter template 

 

 

 

 

 

 

 

https://extensions.sketchup.com/en/content/clf-shape-bender


This is where you will find the shapebender extension or plugin 

 

 

 

You can also add the icon to your toolbar for easy access if you wish 

(view>toolbar>shapebender)  

 

 

 

  

 

 

 



 

Step 3: Import images Ive provided from the instructables attachment.  

(File>Import) 

 

The photos are named front and side. Make sure you have jpeg 

displayed in the bottom scroll menu  

 

 

   

 



 

Step 3: Click one time and Place your image in the workspace. Do not 

press enter or click again 

 

 

 

You will notice that your image scales up and down. At the lower right 

side of your screen there is an input box. Input the number 10000 and 

press enter. Your image should now be to correct scale in sketchup.  

Do the same for the side image.   

 

 



 

Ok, you’ve made it through boring part, Now some 3d modeling! 

 

Step 4: If this is your first go at Sketchup, I recommend becoming familiar 

with the interface. Mainly you will want to be familiar with the toolbar 

(curser, pencil, eraser, etc). Click on the icon that reads Rectangle. 

Click once on the screen, drag the rectangle until sized, and then click 

again or press enter.  

 

 

 

In sketchup it is really easy to extrude basic shapes. On the toolbar look 

for the push/pull icon. You can extrude your square and make it into a 

3d box! 



 

If this is your first time 3d modeling, you just created your first solid 3 

dimensional object! You can 3d print this bad boy, although you 

probably won’t be too impressed.   

 

 

 

Sketchup works with groups and layers. This allows you to isolate 

individual components without messing with the rest of your model. 

From the toolbar select your curser and Triple click the box. Once all the 

edges are blue, right-click and select Make Group from the pulldown 

menu. To enter the group again simply double click.  

 

Youtube is a great resource for learning sketchup. If youde like to learn 



more about groups, click the link below. 

https://www.youtube.com/watch?v=LeKsBMXtmj8 

 
Step 5: In the last step we created a group from a box. The reason 

we’ve included a box in this file is for reference only, mainly rotating. We 

will get back that later. How you doing so far? 3D modeling is a lot more 

intimidating than it seems. Treat it like a video game and you will learn in 

no time!  

 

So now were ready to trace the outer frame! We are going to trace 

over the image creating a flat, 2d Outline. From the toolbar menu 

select the pencil icon. Starting at the upper left corner draw a line from 

left to right and type 4000 mm. If you’re wondering why the crazy scale, 

don’t worry we will adjust this later.  

  
Draw lines projecting downward from the two endpoints. FYI the green 

guide is an indication you are drawing on axis. If no green, your line is 

https://www.youtube.com/watch?v=LeKsBMXtmj8


not straight…Straighten up! lol 

 

 

 

Our mask projects in a bit so we will draw some guides and to locate 

our actual edge. Project a line inwards toward the inside of the mask 

about 150mm. Then complete the triangle. 

 

Using your eraser delete the two triangles surfaces and outside lines. 



Your model should look like the image below. Select the line tool, draw 

a line from the midpoint of the horizontal line toward the lower frame.  
 

 

 

From the toolbar select 2pt arc. Draw a shallow arc like the one below. 

Try to line things up as best as possible but don’t go crazy.  

 

 

 



 

 

 

 

Select your 2 pt arc again and connect the endpoint to your arc. A 

blue surface should appear. This means your now working with a closed 

set of lines/ 

 

 



 

 

 

 

 

Now select your blue surface with the move tool. Once you’ve selected 

the surface click CTRL on your keyboard. This is a shortcup for copy. 

Drag your new surface out to the side.  

 

Next we will mirror this surface and attach it to the original surface. 

Select your surface and right click. From the pulldown menu find Flip 

Along then click on Red Direction. This basically means you are flipping 

or mirroring along the red axis.  



 

Once flipped go ahead and attach it to the original surface. Select on 

the corner with your move tool and drag toward the right upper hand 

corner of the original surface.  

 

After deleting that center line your surface should look like this. 

 

From the toolbar look for offset (two arcs with an arrow). Click on the 

surface to offset inwards. Input 400 mm and delete the center surface. 



 

 

 

Remember to group your object. Triple click and Make Group. 

 

Step 6: model the inner ring 

 

On to the inner ring. Tilt your view a bit and draw a straight line down 

from the upper edge of the ring to the bottom. 



  

Locate the circle tool and from the midpoint of the line draw a circle. 

Notice my circle looks a bit strange. We can adjust the amount of 

facets on the circle by inputting a value which represents the number of 

sides. By default the number is 12, go ahead and adjust it to 48 (Click on 

the circle again, input 48 and enter) 

 

  

 

 

Once you’ve created your smooth circle delete one half. We will scale 

the perfect arc inward creating a half-ellipse. From toolbar find scale.  

You want to scale from outside in and from bottom up or top down (Not 

diagonal as this scales your object proportionally). Again, it doesn’t 

have to be spot on, just ballpark.  



 

Once your happy go ahead and mirror the surface (like in step 5)

 

 

 

 

 

 

 

GROUP!!! 



 

Offset 400 mm 

 

Trace the circle filter, triple click and group 

 

 

 

Finally, double click in each group and extrude each piece 400 mm 



 

 

 

Step 7: BUBBLE TIME… 

 

Please watch this tutorial first. It will clue you in on how to make a sphere 

in skethcup. Trust me its easier when seen live. See how they use the box 

as a reference. Also you can hide the frame and filter in the meantime. 

Edit>Hide 

https://www.youtube.com/watch?v=iDbQhQjeP9g 

 

Draw a line from top to bottom 

 

 

https://www.youtube.com/watch?v=iDbQhQjeP9g


From the midpoint draw your circle again. 

  

Using the box as a reference draw the inner vertical circle (see video 

above). Before making the sphere copy the flat circular surface as it will 

serve as a cutting plane in the next step. 

 

Ahaaa!! Spehere!!! Double click to see the fancy linework 

 



 

Next you will delete the bottom portion of the sphere by pasting your 

circle in place. This is the cutting plane I mentioned.. Edit>Paste in place. 

If you lost it, no sweat just redraw the circle from the midpoint again.  

 

You should now be able to select and delete the bottom portion of the 

sphere 

 

You From the toolbar hit scale and scale the dome inward. Input .99 as 

a scale value. You want to do this from all sides as it will essentially 

proportionally scale your sphere to be smaller than the ring. 

 

 



 

Hows that dome looking? 

 

 

Once your dome is centered in place you can flatten it by scaling 

down toward the image. 

  

 

If you want to change the appearance (material) go 

Window>Materials>Translucent, click your material and with the paint 

bucket change the objects material. (youtube materials sketchup) 

 

 



Edit>Unhide All 

 

Step 8: Position filter cap.  

 

 

 

For this part you will need your reference box.  

 
Holding shift will allow you to rotate your object along your desired axis. 

In this case along the green axis. Tilt your cap about 30 degrees 

 

 



 

Do this again along the red axis. This time about 15-20 degrees should 

do. 

 

You can push/pull the circle until it fully intersects the bubble.  

  

Not perfect but it will do for our prototype. Typically we would print 

these pieces separate so we would lay the filter down flat. 

 

 

 



Step 9: Fit the bubble to the ring and thicken.  

 

Offset the ring in 200mm  

 

 

Push the inner ring down about 200 mm.   

 

 

Double click the dome and draw a line down the center of the 

underside. 

 



 

Double click the dome and draw a line down the center of the 

underside. 

 

 

Scale down the copy .96 proportionally. (click one of the corners of the 

scaling tool and drag inward, input .96). 

 

 

Looking at the underside of the domes, copy the small form the 

midpoint of the line into the larger one. 

 

 



 

It should look like this.  

 

 

Delete the inner face only , leacving the outer circle or trim in place. 

You may have to draw a line along one of the facets to separate the 

Two circles 

 

 

 

You know have a solid and printable dome! 

 

 



Step 9: Adjust scale 

 

As I mentioned earlier you would typically start by using correct sizes. It 

Will allow you to accurately model for prototyping.  

Seeing as I broke rule lets go ahead and fix it. 

 

The mask should be a width of approximately 6-7 inches (175mm) 

The bottom line (above his head) is about 4000 mm. The correct line 

above this line is 175 mm. We need to match the lower line (along with 

the model) to the upper line. (my bad!) 

 

 

Select all your objects and scale. 175/4000 = .04375 , We need to scale 

the entire model down by .04375 

 

 

 

 

 



 It will look like this. Just drag your entire model back to the main axis 

and zoom in. Now everything should be to correct scale for printing. 

Sorry If that was confusing, I usually work in big scale (Architects!) 
 

 

 

Step 10: Almost there. Just a few minor adjustments to the main frame.  

 

At this moment if we pushed to 2mm holes into the frame (for the 

headstrap) we would have a risky print file. Typically you want your walls 

to be above 2 mm. Our frame is roughly 4mm so were good, but if you 

add a 2mm hole for the strap your now looking at 1mm walls on either 

side. No good! So let’s thicken these up. 

 

 

 

 



First drag in the upper inside edge about 5mm 

 

 

Then the bottom inside edge about 3mm. Do this to both sides 

 

 

 

 

 

 



Now create some guides and add holes into your mask 

 

 

I think you’re getting it! 

 



Lastly, Ive add a hole in place of the filter so we can breathe while 

trying on the prototype.  

 

 

 

 

 

 

 

 



Step 11: Shape Bender Time!  

 

Rotate your mask so its standing up right (Group and rotate using the 

box as a reference) 

 

 

 

 

Draw a straight line along the flat edge of the mask. Draw an arc, 

roughly the depth of your face, directly behind it.  You can use the 

second image for reference. 

 

 

 



As we will only be bending the large frame around the arc, make sure it 

is on its own and in a group. Select the group then select the 

shapbender icon tool (Look at the bottom of the screen for prompts 

from sketchup) 

 

 

 

Next select the arc.  

 

 

 

 

 

 



After a minute or two you will see a wireframe preview of the bent 

frame. If you are happy with the result press enter. (see command 

prompt at bottom of skp screen for further instructions) 

 

  

After positioning the face frame in elevation, copy the bubble, ring and 

filter cap as one group and drag toward your new frame.  

 

 

 

 

 

 



 

Nice! Your All Done  

 

 

 

 

Congratulations! 

 

 

 

 

 

 

 



 

 

 

 

 

 

I hope you’ve enjoyed this tutorial. Feel free to message me if you have 

any questions. Your votes and friendly comments are much 

appreciated! 

 

 

 

 

 

 

 

 

 

 


