




ChIMP FRAME BOM
PART QUANTITY NAME NOTES Links

1 1 1 1/2" PVC TEE Readily available SCH 40 plumbing fixtures and pipe. 

2 2 1 1/2" X 4 5/8” PVC STUB AXLE Readily available SCH 40 plumbing fixtures and pipe. 

3 1 1 1/2” TO 1 1/4” PVC ADAPTER Readily available SCH 40 plumbing fixtures and pipe. 

4 1 1 1/4” X 13” PVC LEG Readily available SCH 40 plumbing fixtures and pipe. 

5 1 1 1/4" PVC HIP CROSS Readily available SCH 40 plumbing fixtures and pipe. 

6 1 1 1/4" X 6” PVC TORSO Readily available SCH 40 plumbing fixtures and pipe. 

7 1 1 1/4" PVC CROSS Readily available SCH 40 plumbing fixtures and pipe. 

8 1 1 1/4" X 7” PVC NECK Readily available SCH 40 plumbing fixtures and pipe. 

9 1 1 1/4" PVC CAP Readily available SCH 40 plumbing fixtures and pipe. 

10 2 1 1/4" X 4 1/2” PVC SHOULDER STUB Readily available SCH 40 plumbing fixtures and pipe. 

11 2 1 1/4” TO 1” 90 DEG PVC SHOULDER Readily available SCH 40 plumbing fixtures and pipe. 

12 2 1" X 6 1/2” PVC ARM Readily available SCH 40 plumbing fixtures and pipe. 

13 2 1” 90 DEG ELBOW Readily available SCH 40 plumbing fixtures and pipe. 

14 2 1" X 10 1/2” PVC FOREARM Readily available SCH 40 plumbing fixtures and pipe. 

15 2 1” PVC CAP Readily available SCH 40 plumbing fixtures and pipe. 

16 1 3/4" PVC FRONT PLATE Cut from 1” x 4” PVC Trim Board

17 1 3/4" PVC HIP PLATE Cut from 1" x 6” PVC Trim Board

18 1 3/4” PVC REAR PLATE Cut from 1” x 4” PVC Trim Board

19 2 PLA PRINTED HUB ADAPTER SETS 3D Printed in PLA, 6 Wall, 50% Infill from our .STL File.

20 2 6 1/2” HOVERBOARD MOTORS Source new or used 22 volt 6 1/2” Hoverboard motors

21 5 HEX PAN HEAD ST4.8 X 36MM SCREW Can substitute #10, Slotted, Phillips or Torx Drive

22 2 1 1/4" PIPE STRAP Found at Lowe’s, Home Depot, and Electrical Supply Stores.

23 4 M6 X 15 HEX PAN HEAD BOLT Uses 4mm Hex Bit

24 4 M6 X 12 WASHER

25 4 M6 X 20 WASHER

26 4 M6 NYLOK NUT Uses 10mm Socket

27 10 BACKPACK INSERT Comes Pre-installed in BACKPACK

28 1 BACKPACK (200 X 155 X 80mm) LeMoTech ABS Junction Box or Similar

29 6 L-SHAPED STANDOFF Used in Gaming Consoles and PCB Mounting

30 6 M2.5 X 6 PAN HEAD MACHINE SCREW Comes with L-SHAPED STANDOFF

31 6 M2.5 NYLON INSULATING WASHER For insulating ODRIVE Mounting Screws

32 6 M2.5 FLAT HEAD SELF TAPPING SCREW Comes with L-SHAPED STANDOFF

33 1 ODRIVE VERSION 3.6 ODrive Brushless Motor Controller



ChIMP FRAME INSTRUCTIONS

What follows are the basic ChIMP assembly instructions. In addition to these written instructions, the included 
Assembly Drawings and the online videos should make it clear that the ChIMP is truly simple to build with basic 
hand tools. We strongly advise you to watch the construction videos before beginning construction. If a picture 
is worth a thousand words, what is 30 frames per second worth? :-) Please take your time, have fun, and use 
the forum to get clarification on anything we haven’t made perfectly clear.


Basic ChIMP frame construction instructions:


1. Using clear PVC cement, glue part #3, the 1 1/2” to 1 1/4” PVC ADAPTER into the top connection of part 
#1, the 1 1/2” PVC TEE. Please refer to construction drawings 001 and 002. Make sure you apply the 
cement to BOTH surfaces. Wipe away any stray cement, and hold the pieces together for at least a minute 
to allow the cement to begin to set.


2. Glue both part #2s, the 1 1/2” PVC STUB AXLEs into part #1 as shown in construction drawings 001 and 
002. Hold at least 1 minute to let glue set.


3. Temporarily insert part #4, the 1 1/4” X 13” PVC LEG into part #3. DO NOT GLUE!


4. Glue part #5, the 1 1/4” HIP CROSS into part #4. The HIP CROSS is identified by its having one shorter 
connection, which will face towards the rear as shown in construction drawings 002 and 003. This shorter 
connection allows the wiring to exit for attachment to the ODrive Motor Controller mounted on the #18 PVC 
REAR PLATE.


5. Glue the #17 PVC HIP PLATE down onto the top connection of #5 HIP CROSS, as shown in construction 
drawing 003. The beveled side of the 2” hole faces down. The HIP PLATE should be seated down fully onto the 
HIP CROSS, and the shorter connection must face the rear of the HIP PLATE (towards the battery strap slots). 
The longer connection on the HIP CROSS should face forward and be square with the front edge of the HIP 
PLATE.


6. Pre-drill and screw down the HIP PLATE onto the forward connector of the #5 HIP CROSS as shown on 
drawing 003. This is used to strengthen the hip connection and to prevent rotation.




ChIMP FRAME INSTRUCTIONS

7. Glue part #6, 1 1/4” x 6” TORSO into the top connection of part #5, the 1 1/4” HIP CROSS.


8. Glue part #7, the 1 1/4” PVC CROSS  onto the #6 TORSO, making sure the cross is perpendicular to the #5 
HIP CROSS as shown in construction drawing 002.


9. Insert part #8, the 1 1/4” x 7” PVC NECK into the top of part #7. DO NOT GLUE. Pre-drill and screw.


10. Glue part #9, the 1 1/4” PVC CAP onto part # 8.


11. Glue both part #10s, the 1 1/4” x 4 1/2” SHOULDER STUBs into part # 7, the 1 1/4” PVC CROSS, as shown 
in drawings 001 and 002.


12. Glue both part #15, 1” PVC CAPs onto their respective part #14s, their 1” x 10 1/2” PVC FOREARMs.


13. Glue both #14 1” x 10 1/2” PVC FOREARMs onto their respective part #13s, the 1” 90 DEG PVC ELBOWs.


14. Glue both part # 12s, 1” x 6 1/2” PVC ARMs onto their respective #13 1” 90 DEG PVC ELBOWs.


15. Slide both #11 1 1/4”  to 1” 90 DEG PVC SHOULDERs, and secure them with masking tape, in the position 
shown in drawings 001 and 002.


16. Glue both part # 12, 1” x 6 1/2” PVC ARMs into the taped on #11 1 1/4” to 1’ 90 DEG PVC SHOULDERs, 
making sure the arms are square and perpendicular as shown in drawings 001 and 002.


17. Pre-drill and install both part #11s onto the SHOULDER. These should be installed at a good angle to 
protect the ChIMP during a forward fall, and should both be mounted at the same angle.


18. Referring to construction drawing 004, remove the BACKPACK rear cover and drill the four 6mm holes in 
the BACKPACK, as shown. Using a Dremel or knife and chisel, remove the molded ribbing from the shaded 
areas in the drawing. This will allow the straps and washers to lay correctly while mounting.




ChIMP FRAME INSTRUCTIONS

19. Mount the BACKPACK as shown in drawing 005. Use of a 4mm hex wrench and a 10mm socket on an 
extension is recommended, but a simple hex wrench and a pair of pliers would work in a pinch. 


20. It’s now time to fit the part #19 PLA PRINTED HUB ADAPTER SETs. First, install a set of adapters onto a 
Hoverboard Axle. Remove any excess material as necessary to make the two halves of the adapter meet and 
form a tight fit. The adapter halves must touch when strong pressure is applied. Repeat on the second adapter 
set.


21. Once this fit is accomplished, use sandpaper to slightly bevel the inner edge of the part #2 1 1/2” x 4 5/8” 
PVC AXLE STUBs, so that it will help with the Adapter installation. 


22. Check the fit of the first adapter set into an AXLE STUB. They should be too tight to insert, but not too far 
off. Clamp a pair of Adapters to a work bench vertically. Using a length of 1” - 2” wide abrasive cloth tape (used 
by plumbers) smooth the outside of the Adapter until it can be inserted. This should be a TIGHT FIT that 
requires some force to fully insert. These Adapters are NOT GLUED but held in by friction and a single screw 
acting as a set screw. Repeat with second Adapter set. Do not install fully until the motor wiring is fully 
extended and ready for final assembly. The adapters should be installed with their seam running vertically, 
straight up and down. Pre-drill and install screws at the time of final assembly.


This concludes the assembly of the basic ChIMP frame. Please proceed by viewing the Electronics Videos and 
downloading the Electronics Assembly Manual
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ChIMP BASIC ELECTRONICS BOM
PART QUANTITY NAME NOTES Links

1 1 ODRIVE MOTOR CONTROLLER VER. 3.6 We are using a genuine ODrive, but clones do exist.

2 1 ARDUINO MEGA MICROCONTROLLER R3 Genuine or clone version of the Mega

3 1 ADAFRUIT BNO055 IMU BREAKOUT BOARD The BNO055 is available from many sources, including Amazon

4 1 ASSORTED DUPONT WIRES Purchase an assortment of lengths and connector combinations

5 15’ 5 CONDUCTOR 22AWG RIBBON WIRE Multi-colored stranded wires for extending Hoverboard sensor wires

6 10’ 14GA BLUE STRANDED SILICONE WIRE For extending Hoverboard motor power wires

7 10’ 14GA GREEN STRANDED SILICONE WIRE For extending Hoverboard motor power wires

8 10’ 14GA YELLOW STRANDED SILICONE WIRE For extending Hoverboard motor power wires

9 10’ 22GA RED SOLID WIRE Used for breadboard wiring

10 10’ 22GA BLACK SOLID WIRE Used for breadboard wiring

11 1 3D PRINTED ARDUINO MEGA MOUNT STL Available on website

12 1 400 PIN, 3 1/4” X 2 1/8” BREADBOARD Adhesive backed, with buss strips lengthwise

13 2 6 1/2” 24 VOLT HOVERBOARD MOTOR Salvaged or purchased new

14 1 5000Ah - 6000Ah 22.2 VOLT LIPO BATTERY XT60 Connector, 40C or higher discharge rate

15 1 XT60 PIGTAIL WITH SILICONE WIRES Used to connect battery to ODrive board

16 1pk 3M COMMAND LRG PICTURE HANGERS Holds up to 16 lbs, several pairs for mounting Arduino, etc.

17 1 6S LIPO CHARGER AC or DC 6 cell Li-Poly charger w/ XT60 connector

18 1 2.54mm DUPONT CONNECTOR KIT With crimper and 1, 2, 3, 4, 5, and 6 pole connectors

19 1 2.4Ghz 5.8Ghz WiFi ANTENNA U.FL/IPEX to RP-SMA female stub antenna





Programming, Testing, and Setting up a ChIMP


If this seems foreign, do not fear. Our community is there to support you. No one is 
born with this knowledge! 

THE ARDUINO MEGA:

Arduino IDE (Integrated Development Environment) Installation and setup:

The first step is to download the latest Arduino IDE from here, and install it on your PC. 
This program allows you to modify and upload programs (Sketches in Arduino speak) onto 
your Arduino Microcontroller.


After installation, connect your Arduino Mega to the PC via USB and restart the IDE. Under 
Tools > Board, select “Arduino/Genuino Mega or Mega 2560” and under Tools > Port select 
the port your Arduino is connected to.


Open the Serial Monitor under Tools > Serial Monitor and set the baudrate to 115200 (just 
to make sure there won't be issues with this later). Close the Serial Monitor again.


Test your general setup:

Under File > Examples < 01.Basics select ”Blink”. The IDE will display the respective Code 
in a new window. Click on “Upload” (the right pointing arrow in the top left corner in the 
IDE). The code should get compiled and then be uploaded to the Arduino. After successful 

https://www.arduino.cc/en/Main/Software


upload, the Arduino's LED should blink steadily. You can change the values of delay() in 
lines 34 and 36 (times in milliseconds) and re-upload to change the blinking pattern. This 
test is powered by the USB connection…NO BATTERY NEEDED, AND IT SHOULD 
REMAIN UNCONNECTED!

Test the IMU:

After following the Electronics videos, and wiring up your ChIMP as shown in the included 
Fritzing Wiring Diagram (and then double checking EVERYTHING), it's time to test the 
IMU.


To easily use this relatively complicated sensor we need two software libraries that will do 
all the heavy lifting for us. Those are also provided by Adafruit here  (sensor driver) and 
here (unified sensor interface). Installing and using libraries from GitHub is explained 
in Annex I.

To test if the sensor is working, start (or restart) your Arduino IDE, connect the Arduino with 
attached IMU and open the sensorapi example (as described here). Compile and download 
the code to the Arduino, open the Serial Monitor (to be found under tools; make sure the 
baudrate matches that in the code) and watch the stream of orientation data coming in as 
you tilt and turn your ChIMP! You are getting there! This test is powered by the USB 
connection…NO BATTERY NEEDED, AND IT SHOULD REMAIN UNCONNECTED!

Test the RC receiver:

Standard RC receivers run on 5 Volts, so they require 5V and GND from a power supply. 
The connectors of a receiver typically have three pins for each servo, with one for 5V, one 

https://github.com/adafruit/Adafruit_BNO055
https://github.com/adafruit/Adafruit_Sensor
https://learn.adafruit.com/adafruit-bno055-absolute-orientation-sensor/arduino-code#sensorapi-example-4-13


for GND and one for the signal. The Positive and Ground power pins are each wired in 
parallel (all together), hence GND can be connected to any GND pin and 5V can be 
connected to any 5V pin.


The signal for each channel is encoded using PWM (pulse width modulation). For 
standard RC equipment, a pulse is sent 50 times per second. The duration of this pulse, 
which typically ranges from 1 to 2 ms long, is the signal. ChIMP needs three signals 
(throttle, steering and enable), thus three signal pins of the receiver are connected to the 
Arduino. You choose the 3 channels based on how your RC Transmitter is laid out, and 
how you want your controls to work. There are different ways of reading PWM input signals 
on an Arduino, but the most efficient one is to use interrupts. This ensures that the 
Arduino's processor is never busy waiting for the next pulse. By using interrupts, special 
hardware inside the Arduino’s microcontroller is used for triggering an interrupt service 
routine only when the processor really needs to do something (i.e. calculating the duration 
of the pulse). The downside is that this only works on dedicated pins, of which smaller 
Arduinos only have two. This is the reason that ChIMP needs an Arduino Mega which 
provides six interrupt pins.


For testing, wire up the receiver as described in the Chimp Electronics Videos and the 
Wiring Diagram. Connect the three channels you want to use to control the robot to the 
Arduino pins 2, 3 and 18 (as defined in the config file). Normally Pin 2 is for Steering, Pin 3 
is for Throttle, and Pin 18 is for the Enable (used as a failsafe, the Enable must be "On" for 
the Chimp to balance and operate)


https://en.wikipedia.org/wiki/Pulse-width_modulation#/media/File:Duty_cycle_general.svg
https://www.arduino.cc/reference/en/language/functions/external-interrupts/attachinterrupt/
https://en.wikipedia.org/wiki/Interrupt_handler
https://en.wikipedia.org/wiki/Interrupt_handler
https://github.com/LuSeKa/HoverBot/blob/master/config.h#L6


Upload the receiver_test sketch in the tests subfolder to the Arduino.This test is powered 
by the USB connection. NO BATTERY IS NECESSARY FOR THIS TEST, AND IT 
SHOULD REMAIN UNCONNECTED!

Once the sketch is uploaded and running, open the Serial Plotter in the Arduino IDE (Tools 
> Serial Plotter). As you move the sticks on the RC transmitter, you should see three curves 
react accordingly. They show the three signals’ pulse widths in microseconds and should 
be centered roughly around 1500, ranging from 1000 to 2000.


ODrive Motor Controller Wiring:


Power and Motors:

The ODrive is powered from the battery via its DC Terminals, and each motor's three 
phases (A, B, C, Blue, Yellow and Green) are connected to one of its motor output 
terminals (M0 and M1). The ChIMPs righthand motor (his right hand) is connected to M1, 
his left connected to M0. The order in which the motor wires are connected does not 
matter, as the ODrive figures this out by itself during calibration.


Auxiliary resistor:

Since the ChIMP is running on batteries, generally no auxiliary braking resistor is required 
(the ODrive dumps recuperated energy back into the battery). However, depending on the 
type of battery you are using, the resistor might help avoid issues on the power bus that 
could lead to the ODrive unexpectedly shutting down.


https://github.com/LuSeKa/HoverBot/tree/master/tests/receiver_test


Hall sensors:

Each hoverboard motor comes with internal Hall (magnetic) sensors that tell the ODrive 
when to power which of the three motor phases. Each Hall sensor set has five wires: Two 
for power (5V, usually red and GND, usually black) and three for signal (often blue, yellow 
and green). A motor's Hall sensors are connected using extension cables to the 
corresponding sensor inputs (M0 and M1) on the ODrive's J4 connector. The three signal 
lines are connected to inputs A, B and Z where the order again does not matter. You will 
probably need to make an extension cable (the shorter the better for the signal). Note that it 
is necessary to add a 22nF capacitor between each of the three signals lines and ground 
for signal integrity. Charleston Robotics has developed a neat little PC board that 
incorporates these capacitors along with a header and pads to solder your extension wires. 
Look for them shortly on our website!


Configuring the ODrive:


To configure the ODrive for the ChIMP you need to first install the ODrive tools software 
and setup the necessary drivers. There is a comprehensive explanation of how to do this 
for different operating systems here.


The tools include the odrivetool interactive shell and a Python3 library. Once they are 
installed and the drivers are working you can get started talking to the ODrive via the 
odrivetool over USB. You can (but it is not recommended) setup the ODrive following these 
instructions (replacing CTRL_MODE_VELOCITY_CONTROL with 

https://docs.odriverobotics.com/#downloading-and-installing-tools
https://docs.odriverobotics.com/hoverboard.html
https://docs.odriverobotics.com/hoverboard.html


CTRL_MODE_CURRENT_CONTROL and omitting anything to do with PWM and 
automatic startup).


The recommended way is to use these two Python scripts that handle the entire setup 
for ChIMP. All you need to do is:


• Wire up the ODrive and the motors

• Power up the ODrive by plugging in the battery for the first time.
• Make sure both motors are ABSOLUTELY FREE TO TURN, PROP UP AND 

STEADY THE ChIMP!
• Connect the ODrive to your computer via USB.

• Run the first script ODrive_hoverboard_motor_setup_part_01.py
• Run the second script ODrive_hoverboard_motor_setup_part_02.py (or run 

the motor specific scripts if you want to calibrate the motors separately).

You can use the interactive odrivetool to check if the motors are working as expected, or 
you can go right to the next step!


Remote control the motors via the Arduino:

Now that the ODrive is ready to use and the Arduino receives the RC signals, you can 
control the motors via the remote control. 


Wiring:

The Odrive provides enough power from it's 5V regulated output to power the Arduino and 
the receiver. You also need to connect the Arduino’s serial interface to the ODrive - an 
overview over all necessary connections is shown on the ChIMP Wiring Diagram.


https://github.com/LuSeKa/HoverBot/tree/master/tools
https://github.com/LuSeKa/HoverBot/blob/master/tools/ODrive_hoverboard_motor_setup_part_01.py
https://github.com/LuSeKa/HoverBot/blob/master/tools/ODrive_hoverboard_motor_setup_part_02.py


Code:

Once the ODrive, the motors, the Arduino and the receiver are wired up, you can upload 
this test project to the Arduino Mega. 


Test:

MAKE SURE THE ROBOT IS PROPPED UP AND THE WHEELS CAN TURN FREELY!

Connect the battery to the ODrive. You should see the Arduino’s LED flashing, indicating 
that the 5V power supply from the ODrive is working.


The motors should be in idle mode. Activate them by sliding/switching/turning the 
respective knob (Stick) on the RC transmitter. After that, check if they move when you 
move the sticks. Applying throttle should make them turn in the same direction, applying 
steering should make them turn in opposite directions. If that’s not the case, adjust one of 
the MOTORDIR definitions in the config.h, recompile and reupload.


Control the motors by tilting the IMU:

At this stage, you can go ahead and compile and upload the complete HoverBot.ino file 
onto your robot. For testing, again make sure that the wheels are free to turn!

Once you turn on the robot, the blinking LED indicates that communication with the IMU is 
established and the system is ready to go. If the LED does not blink, something is wrong 
with the IMU.


https://github.com/LuSeKa/HoverBot/tree/master/tests/odrive_test


In addition to reacting to the RC commands, once activated the wheels will now also react 
to the tilt of the vehicle. Tilting forward should make them turn forward, tilting backward 
should result in the wheels turning backward. Think of balancing a ruler in your palm: if it 
falls away from you, you must quickly move your hand forward to catch its fall...Rotating the 
robot around the vertical axis should make the wheels counter-rotate - this helps with 
driving straight.


Controller tuning:

The controller is based on five parameters:


• KP_BALANCE: Determines how much the robot reacts to leaning forward or 
backward. A high value might lead to tilt oscillations


• KD_BALANCE: Determines how much the robot reacts to the rate of tilt change. 
It generally dampens oscillations, but a value too high might lead to increased 
oscillations (mainly due to time lags in the control loop)


• KP_POSITION: Determines how strongly the robot reacts to RC throttle 
commands


• KP_STEERING: Determines how strongly the robot reacts to RC steering 
commands


• KD_ORIENTATION: Determines how much the robot tries to counteract turning 
around the vertical axis - higher values make going straight easier but turning slower


Tuning these parameters is not trivial and generally is a tedious, iterative process (test, 
change, compile, upload, repeat). However, the default parameters should be a very good 
start and if anything you should only need to change the first one (KP_BALANCE). If the 



robot does not seem to balance well, try a (slightly!) higher value. If it oscillates, try a 
(slightly!) smaller value.


Change the parameter in the config.h accordingly, recompile and reupload.


Annex 1. Installing Arduino Libraries from Github:


Installing Libraries:

Software libraries are an efficient and common way to encapsulate and distribute pieces of 
reusable code (such as sensor drivers) that are not expected to need to be changed by the 
user. A library typically consists of two files, a header file (.h) and a source file (.cpp). Some 
libraries consist only of a header file, some contain additional files or even subfolders.


Using a library in an Arduino project generally requires two steps: 


• Placing all files (.h and .cpp) in a subfolder of your Arduino IDE’s libraries folder. 
The libraries folder is created automatically upon installation of the IDE. The subfolder 
needs to have the same name as the library. This step is referred to as “manual 
installation” in the official Arduino tutorial on the topic. 


• At the top of your Arduino sketch, including the library with a precompiler 
instruction that looks something like #include <myLibrary.h>. This line of code 
alternatively gets created automatically when you click Sketch>Include 
Library>myLibrary as is shown at the very bottom of the tutorial.


https://www.arduino.cc/en/Guide/Libraries#toc5
https://www.arduino.cc/en/Guide/Libraries


Getting the Code from GitHub:

Many open-source projects (such as our ChIMP) are hosted on GitHub, which is an online 
platform building on the powerful and widely used software version control tool Git. On any 
project main page, there is a green button captioned “Clone or download”. 


If you are familiar with Git you can simply clone the entire project into the right folder, e.g. 
into a subfolder of the Arduino libraries folder in case of an Arduino library. If not, simply 
click on “Download ZIP” and, once downloaded, extract the archive into a subfolder of the 
libraries folder. Alternatively, you can use the Arduino IDE’s built-in functionality to 
include ZIP libraries, described here.

Note: You will need to restart your Arduino IDE after installing a library before you can use 
it in your code.

https://www.arduino.cc/en/Guide/Libraries#toc4

