1.

2.

3.

Open ‘Inkscape’.

Laser Engraved Filled Images and Letters

by: Ed Powell

Go to ‘File’ > ‘Document Properties’ (Fig 1).

Change settings as shown below: (This may need to be adjusted to your machine’s size.) (Fig. 2)
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(Fig. 1 — Open Document Properties)

Q Document Properties (Shift+Ctrl+D) - O X
@’J Document Properties (Shift+Ctrl+D)

General
Default upits:
Pagg Size
T 210.0%297.0 mm
US Legal 8.5x14.0in
SEreeuti 73x105in v
Orientation: @ Portrait
Custom size

Width: | 8.50000 Unitss [in  [™)

Height: | 11.00000

CRRE L

[ Resize page to content...

Display
Show page border
[] Border on top of drawing
Show border shadow
Use antialiasing
Background color: Fels=slss
Border color: NG

(Fig. 2 — Change settings)
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4,
5.

6.

Close the ‘Document Properties’ window.

In the ‘Extensions’ menu select ‘Gcode Tools’ and ‘Orientation Points’. (Fig. 3)

;  Extensions Help

: Previous Extension Alt+Q . 0.000 ~fin V 23T
L‘. Previous Extension Settings... Shift+Alt+Q L NN
Arrange ’
Color »
Export »
Gcodetools 4 About...
Generate from Path » Area...
Generate Laser Gcode 4 Check for updates...
Images » DXF Points...
Jessylnk » Engraving...
Modify Path ’ Graffiti...
Raster » Lathe...
Render » Orientation points...
Stylesheet 4 Path to Gcode...
Text » Prepare path for plasma...
Typography 4 Tools library...
Visualize Path »
Web »

(Fig. 3 — Open ‘Orientation points...” dialogue.)

Type in the settings as shown below: (Fig. 4)

0 Orientation points

Orientation Help

Orientation type:

2-points mode

® (move and rotate,
maintained aspect ratio X/Y)

3-points mode
(O (move, rotate and mirror,
different X/Y scale)

O graffiti points

(O in-out reference point
Z surface: 0.00000 5
Z depth: 000000

Units (mm orin): |in v

Orientation points are used to calculate transformation
(offset,scale,mirror,rotation in XY plane) of the path.
3-points mode only: do not put all three into one line (use 2-
points mode instead).

You can modify Z surface, Z depth values later using text tool
(3rd coordinates).

If there are no orientation points inside current layer they are
taken from the upper layer.

Do not ungroup orientation points! You can select them
using double click to enter the group or by Ctrl+Click.

Now press apply to create control points (independent set for
each layer).

[ Live preview

Close

(Fig. 4 — Change settings to match these.)
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7. Orientation points will be placed near the bottom of your workspace area. Depending on how your GRBL code is
set up, you might have to move them. Mine go in the upper right-hand corner of the workspace area. Just click
on the orientation points and drag them to the area where you want them. (Fig. 5)

(Fig. 5 — Click on and drag orientation points to desired location.)

8. In the ‘Extensions’ menu select ‘Gcode Tools’ and ‘Tools Library...”. (Fig. 6)
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(Fig. 6 — Enter ‘Tools Library’ dialogue.)

9. Select ‘Plasma’ and ‘Apply’. (Fig.7)
0 Took Marary o

Toek ltvary Help

Tools type ) defaur
) cyfinder
B ene
& plasma
) tangent Anifte
_) lathe cuttes
) graffel

") Just check tools

Selected toal type fills spproprute default vaboes. You cen
change these values using the Tet tool later on

The topenost (7 order) tool o the active Ryyer is used. if there
i no tocl mnide the currert layer it 15 taken from the upper
layer

Press Apply t0 create new tood

] Live preview
Close | Apply

(Fig. 7 — Select ‘plasma’ and click ‘Apply’)
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10. Click on the Zoom’ tool on the left menu and click on the green box that appeared in the last step. Then click
on the ‘Text tool’. (Fig. 8)
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(Fig. 8 — Zoom in on the green box.)

11. Change the settings to match those below. (Fig. 9)

(Fig. 9 — Change the settings to match these.)

12, Click on the ‘Text’ tool again and type some letters. Drag them where you want them by clicking on the ‘Select’
tool > your letters > and then drag where you want. (Fig. 10)

/(nlo; 0.0; 0.0} /(5.0; 0.0; 0.0)

HAPPY

(Fig. 10 — Drag you letters where you want them in your workspace.)
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13.

14.

15.

16.

17.

With the ‘Select’ tool active, click on the letters to select them.

Click on ‘File’ > ‘Export PNG Image...’

Change the settings in the box as shown below: (Just change the file name and dpi settings) (Fig. 11)

SeExport PNG Image (Shift+Ctrl+E) = [

Export area

Page Drawigg ustom
X0 5453 = 9.080 %
x1: 7.564 3 yl: 9565 17

Width:  |2111 7 Height  |0485 |7
Units: |in v

Image size

Width: | 1267 %

Height: 291 =

Filename
Stuff\lnkscape Fi Export As,
Batch export all selected objects
[] Hide all except selected
[] Close when complete Qf Export

(Fig. 11 — Change settings to match these.)
Click ‘Export’.

Click ‘File’ > ‘Import...” . (Fig. 12)
e *8 x11Blankexperiment.svg - Inkscape
File Edit View Layer Object Path Text Fil

[ New Ctrl+N
E‘J Templates... Crl+Alt+N ||
=1 Open.. Ctrl+0
Open Recent »
[¥] Revert
E Save Ctrl+S
E Save As... Shift+Ctrl+S &
Save a Copy... Shift+Ctri+Alt+S
-7 Import... Ctrl+|
[ Export PNG Image... Shift+Ctrl+E

= Import Clip Art...
&, Pprint.. Ctrl+P

& Clean up document

{7] Document Properties... Shift+Ctrl+D
3¢ Close Ctri+W
gl Quit Ctrl+Q

- (Iéig. 12 — Click to import.)
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18. Select the file you just exported. (Fig. 13)

W Setect file to snpont x
Lok n dacape Fles or =8
* Narne Dete modified Type | P pY
#18181s0k 2152016 101880 SVGE \l 'A |
Quicksccass  Shg) 1Blankespenment 12016 1131AM  SVGC
F & Bertlry Symbcl WY RIEPM  SVGT 15k8
2 | BigHsllc VI/METOPM  VGE 1267 x 281
Deskeoy o | Blank Temglate 1&2PM  WGE
& | Dees_Skutl 13RSTPM SVGL
™ # [Ferran_Symbol 15 10625 PM  SNGT
Liboras 2 Filedt Ferrani Symbel VIS IRIZPM  SVGT
W Happy IINEIIPM_ PNG )
Q d Helo_mm{\'lcm_ NV 48P SVGE
Tha PC 2 Lyl o typel PG image 206 4PM  VGE
Bk il o e IS016504PM  SVGE
@ 2 | Lykan2 2l 1 WGL
Net & o Spaderman 2013 10220 VG
< >
Fie nwme Hasor
Fhes of type N rkacepe Fies v Canced
(Fig. 13 — Select your newly exported file.)
19. The new file comes in on the page. (Fig. 14)
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Original l IAF F .
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PNG HAPPY;E .

(Fig. 14 — The new file comes in as a .png file.)

20. Select the .png file to highlight it.
21. Select ‘Path’ > ‘Trace Bitmap...’ from the menu at the top of the window.
22. Just click ‘Apply’ on the ‘Trace Bitmap Settings’ window.

23. Click on the .png text image and drag the new ‘traced’ image below it. (Fig. 15)
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(Fig. 15 — Click on and drage the traced image off of the .png image.)
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Select ‘Path’ > ‘Object to Path’ with the traced image highlighted. (Fig. 16)

Path Text Filters Extensions Help

@, ObjecttoPath  Shift+Ctri+C 5

e Stroke to Path % Ctrl+Alt+C
D Trace Bitmap... Shift+Alt+B
me N A

(Fig. 16 — Select ‘Object to Path’.)

Select ‘Extensions’ > ‘Gcodetools’ > ‘Area’: (Fig. 17)

Exteprions el
Previous Edtension ARQ & 0425 Tlin [AIREm
Erevious Edension Settngs.. Shifte AR+ Q L i ”, - it .
Artenge v
Color ’
brport . f
Geadetoon L3 Aboct
Generats from Path ’ Rees. [._ l
Generate Laser Geode ’ Check for Sastes. |
Images » DXF Pownts.. r
Jeswyiric ’ [rgraving.
Modidy Puth ’ Graffts.
Raster ’ Lathe.
Render L3 Onentation ponts...
Sepleshest L3 Path to Geode.
Tt ’ Prapare path for plasms.,.
Typography ’ Took lRvary..
Vizalae Path L4
.
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(Fig. 17 — Enter ‘Area’ dialogue.)

Select the ‘Fill Area’ tab and make sure settings are as shown: (Fig. 18)

@ Area X

Area Fillarea Area artifacts Path to Gcode Options Preferences Help

Area fill angle 0.0 =
Area fill shift 00
Area fill shift 00
Filling method @® Zigzag

O Spiral
[J Live preview

o

(Fig. 18 — Make sure settings match these.)
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27. Click ‘Apply’ and wait until you see blue lines all over your text image as shown: (Fig. 19)

HAPPY

(Fig. 19 — Text/image area should fill with blue lines.)

28. Click and drag a box around the image to highlight it. (Figs. 20 & 21)

FNG T I/ T 1

Traced H A P PY

(Fig. 20 — Drag a box around the traced letters.)

(Fig. 21 — Everything should be highlighted now.)
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29.

Go to ‘Extensions’ > ‘Gcodtools’ > ‘Area’ and click on each of the tabs to make sure the settings are as shown in

the pictures below.
@ ces X
Ares Fillarea Asres attdfacts Path to Grode Options . Preferences Help
Masmum area cuttng curves: B =
Area width: ~10.0 =
Ares tool overlap (0.0.9) 00 =
“Create area offset”: creates several Inkscape path offsets to [f‘
48 ceiginal path's area up 1o "Area adiu” value,
Qutines start from “1/2 D” up to “Area width” total width
with "D steps whevs D is taken from the nearest 100!
defmition “Tool diameter” value),
Only one offset will be created if the "Area width® is equal to
20
[ Live preview
) =
@ Area X
Area Fillarea Area artifacts Pathto Gcode Options Preferences Help
Artifact diameter: { m*@
Action: @ mark with an arrow
O mark with style
O delete
Usage:
1. Select all Area Offsets (gray outlines) [%
2. Object/Ungroup (Shift+Ctrl+G)
3. Press Apply
Suspected small objects will be marked out by colored arrows.
[ Live preview
| Cose [ ey |

’ Area

x

Area Fll ores Area atifacts Pathto Geode Options Preferences Help

Area Tl angle
Area fill shift

Asea fill shift
Filing method

] Live proview

0 Area

Close

)
Q0
o0

® Zigaag

) Spural

LR R

X

Area Fill area Area artifacts Pathto Gcode Options Preferences Help

Scale along Z axis:
Offset along Z axis:
[4] Select all paths if nothing is selected

Minimum arc radius:

Comment Geode: \

[ Get additional comments from object's properties

[ Live preview

1
| |

Apply ]
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0 Area X

Area Fillarea Area artifacts Pathto Gcode Options Preferences Help

Biarc interpolation tolerance: i!' 0000
Maximum splitting depth: 4 =

Cutting order: Subpath by subpath |~

Depth function: | d
[J Sort paths to reduse rapid distance [«\&

Biarc interpolation tolerance is the maximum distance
between path and its approximation.

The segment will be split into two segments if the distance
between path's segment and its approximation exceeds biarc
interpelation tolerance.

For depth function c=color intensity from 0.0 (white) to 1.0
(black), d is the depth defined by orientation points, s -
surface defined by orientation points.

[J Live preview
Close Apply
5.
@ Area X
Area Fill area Area artifacts Pathto Gcode Options Preferences Help
Area fill angle 00 £
Area fill shift 00
Area fill shift 00 7
Filling method @ Zigzag
O Spiral
[ Live preview
Close . Apply
7. ' :
30.

Q Area X

Area Fill area Area artifacts Pathto Gcode Options Preferences Help
File: | (RETSToY
Add numeric suffix to filename

Directory: | C:\Inkscape

Z safe height for GO0 move over blank: 0.00000 :
Units (mm orin): |in -
Post-processor: |Round all values to 4 digits v

Additional post-processor:
[] Generate log file

Full path to log file:

[ Live preview

Close

Apply

Click the ‘Area’ > ‘Path to Gcode’ tab and select ‘Apply’. (This will change the blue lines into the actual toolpath
in gcodetools.) You will see arrows indicating where the tool (laser) will travel. (Fig. 22)

(Fig. 22 — Arrows appear to show toolpath.)
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31. You can now open the file in Universal Gcode Sender (UGCS) (what | use) and send it to your engraver.

Note: This process works for filling images as well. You might have to experiment with settings to improve quality, but
this is what worked for me.

Below are a few pictures of my machine, based on this one: 2W Arduino Laser Engraver/Cutter by AlexP66 from the
Instructables website.
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http://www.instructables.com/id/2W-Arduino-Laser-EngraverCutter/
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