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SPICE Netlist Simulation Using 
NI LabVIEW and NI Multisim 

  

 

Estimated time to complete: 45 minutes 

 

Introduction 
This tutorial demonstrates the step-by-step process to run text-based SPICE 

netlist simulations from NI LabVIEW. NI Multisim is used as the simulation 

engine and it is run in a background process connected to LabVIEW using the 

LabVIEW Multisim API Toolkit. 

The LabVIEW Multisim API Toolkit is installed by Multisim and it provides 

over 80 VIs to control a Multisim application instance from LabVIEW. In this 

tutorial, you will explore the functionality of the SPICE command line interface 

this toolkit offers. 

 

 
Tip Consult the toolkit Help to find programming guides, flowcharts and the toolkit VI reference. 

 From LabVIEW, select Help»NI Multisim API Toolkit Help. 

 From Multisim, select Help»Multisim help, and select the Automation API topic. 

 

Objectives 

 Create and modify a netlist file from a Multisim circuit file 

 Create and modify a SPICE nutmeg command file 

 Use LabVIEW to build a VI that will execute the SPICE nutmeg 

command file 

 Display results from the simulation 

There are multiple use-cases for this type of simulation, especially tailored for 

advanced SPICE users. Some of them may range from old library of SPICE files 

that you wish to simulate, make a batch process to run analyses on a directory of 

files, dynamically modify netlist files or analysis parameters to see differences, 

and so on. 

This demo script assumes that the user has working knowledge of LabVIEW and 

Multisim, and understands the basics of SPICE. Even though the LabVIEW code 

in this tutorial looks simple, it is in fact intended for advanced users that are 

comfortable working with SPICE netlist and analyses. 

 



 

Page 2 

Requirements 

 NI LabVIEW 2013 or higher 

 NI Multisim 14.0 or higher (Power Pro or Education Editions) 

 LabVIEW Multisim API Toolkit (installed by Multisim) 

 Files in the SPICE Command Line folder located in the Multisim 

samples folder 

 

 
Note In a typical Multisim installation, the samples folder is in this location: 

C:\Users\Public\Documents\National Instruments\Circuit Design Suite 

<version>\samples\LabVIEW Multisim API Toolkit\ 

Another way to find the samples folder in Multisim is to select File»Open samples, and take note 

of the folder location in the explorer window. 

 

Create your own vs. use sample files 

If you would like to follow this tutorial and create your own files all you need to 

start is the SPICE Command Line.ms* Multisim design file from the 

samples folder. Then follow the implementation instructions of this tutorial. 

If you just want to quickly see the demonstration and/or study the sample code 

provided, grab all the files in the SPICE Command Line folder, and run the 

SPICE Command Line.vi LabVIEW VI. 

 

 
Tip We recommend that you try to create your own files to get the most out of this exercise. 

 

Command Line VI 
In the implementation section later in this tutorial you will review the necessary 

code to connect to Multisim, simulate and then disconnect. However, the 

particular VI that will run the SPICE analysis is called Command Line VI. 

 

 

 

This VI is found in the functions palette, under the Connectivity » Multisim » 

Simulation and Analyses subpalette. The short name displayed in the subpalette 

for this VI is Command Line. 
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Two file paths are needed as terminals. These are the Command File and the 

Log File. You will create and/or specify these paths later. 

 Command File—this is a SPICE nutmeg command file, which includes 

instructions on what SPICE netlist to simulate, what analysis to run (and 

its parameters), and where to store the results. You will create this file 

with information from Multisim. 

 Log File—this is a text file created during simulation, it lists every single 

command sent to the SPICE engine and the outcome of the command. 

Two other files are involved in a SPICE command line simulation, the SPICE 

netlist and the raw data files. These two file paths are specified inside the 

Command File. 

 SPICE Netlist File—this is the circuit description as a regular text-based 

SPICE netlist. You will create this file from Multisim. 

 Raw Data File—this is a text file created during simulation, which 

stores the simulation results. You will parse this file to get the results. 

The Command Line VI does not return the simulation results in a convenient 

LabVIEW-formatted data structure like other API toolkit VIs (for example, 

Waveform format). Inside the Command File you will specify the file path of the 

Raw Data file where the results will be saved in text format. You will then use 

LabVIEW File I/O and String VIs to properly parse the Raw Data file.  

Standard SPICE netlist files from sources other than Multisim can also be used. 

Typically, you will see in the same netlist the circuit description and the analysis 

to run. To use the Command Line VI for that type of file, we suggest that you 

split such netlist into two files, one that only describes the circuit (SPICE Netlist 

File), and a second file that describes the analysis to run (Command File). 

 

Implementation 
This section contains the step-by-step instructions to create your own SPICE 

netlist files and the VI. 

Numbered lines provide the high-level task. The square-bulleted lines explain in 

greater detail the steps needed to accomplish that task. 

Multisim 

1. Get all the files.  

 Group all the files included in the folder of this demo script into a 

new directory. In this way you will be able to modify them without 

compromising the originals. 

 If you are going to create your own files, only use the SPICE 

Command Line.ms* Multisim design file. The tutorial 

instructions are designed for this case. 

2. Load the circuit file. 
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 Launch Multisim. 

 Select File » Open, and select the SPICE Command Line.ms* 

file. 

 Click Open to load the file and review the circuit. 

3. Create the SPICE netlist file. 

 Select Transfer » Export SPICE netlist. 

 Leave the default name or use SPICENetlist.cir. Navigate to 

the same folder as the circuit file. 

 Click Save. 

 You can open the file in Notepad® if you wish to review the results 

of this export; it is a text file. This is a typical SPICE netlist created 

by Multisim from the loaded circuit. 

4. Create a sample SPICE nutmeg command file. 

 Select Simulate » Analyses » Transient analysis. 

 Select the Output tab, and confirm that V(output)and 

V(input) are listed inside Selected variables for analysis. 

 Select the Summary tab, and expand the Representation as SPICE 

commands branch. 

 Launch Notepad® or any other text editor, and type all the command 

lines starting from begin-scope to end-scope. 

 You should end up with text similar to the following code snippet: 

begin-scope page Transient Analysis 

checknodes 3 

save $input $output 

iplot $input $output 

iplotExt $input[3 0] $output[3 0] 

DigitalThreshold 2.500000 2.500000 

set trtol = 7 

set itl4 = 100 

set convlimit 

set rshunt = 1e+012 

set dynamicdc 

set inertialdelay 

-param hrange 0 1e-005 

tran -env-options 1e-005 0.000010000000000000001 0 1e-005 auto_ic 

auto_tstep auto_tmax 

if-error end-scope audit-log-show 

show all 

showmod all 

write-and-destroy-iplot "RawData.tmp" 

end-scope 
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 In Notepad®, select File » Save. Enter the name 

SPICENutmeg.cir for the file and browse to the same directory 

as the netlist file of Step 3.  

 Click Save. 

 Close Multisim. 

 
Note This tutorial shows a transient analysis. If you need to run any other SPICE analysis, in particular 

those that are not included in the LabVIEW Multisim API Toolkit, you can get the correct SPICE 

nutmeg commands from the same Summary tab on any Multisim analysis. 
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5. Modify the SPICE nutmeg command file. 

There are multiple sections that need to be modified from the nutmeg 

command file before it can be used. 

 Specify the source SPICE netlist file. Enter the following code 

before the begin-scope line shown below: 

source "C:\MyDirectory\SPICENetlist.cir" 

Where MyDirectory is the location in your disk where the 

exported SPICE netlist file from Step 3 was saved to.  

One of the subVIs included in the tutorial folder can create local 

paths. If you don’t want to hard-code the file path, you can let the 

subVI (explained later) take care of the paths. If you are using this 

subVI then just leave the filename with extension inside the quotes 

(no full path), and also make sure that the SPICE netlist file was 

saved as SPICENetlist.cir for this subVI to work. 

 
Note If you are hard-coding file paths, use the full file path to the SPICE netlist file and enclose it with 

double quotes (“”). 

 Notice in the SPICE nutmeg command file, the selected variables in 

Multisim to simulate were renamed from V(output)and 

V(input) to $output and $input, this is an internal 

convention used in the Multisim engine. You will see these two 

variables listed in the save and the iplot lines in the code. 

 Specify the raw data results file so that it is located within the same 

directory as your *.cir files: 

write-and-destroy-iplot "C:\MyDirectory\RawData.tmp" 

If you are going to use the tutorial subVI for creating local paths then 

just leave RawData.tmp. 

 The final nutmeg file should look like the following code snippet. 
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source "C:\MyDirectory\SPICENetlist.cir" 

begin-scope page Transient Analysis 

checknodes 3 

save $input $output 

iplot $input $output 

iplotExt $input[3 0] $output[3 0] 

DigitalThreshold 2.500000 2.500000 

set trtol = 7 

set itl4 = 100 

set convlimit 

set rshunt = 1e+012 

set dynamicdc 

set inertialdelay 

-param hrange 0 1e-005 

tran -env-options 1e-005 0.000010000000000000001 0 1e-005 auto_ic 

auto_tstep auto_tmax 

if-error end-scope audit-log-show 

show all 

showmod all 

write-and-destroy-iplot "C:\MyDirectory\RawData.tmp" 

end-scope 

The file paths should point to either a hard-coded path, or just to the 

filenames indicated if you are planning to use the tutorial subVI. 

This SPICE nutmeg command file will execute the analysis 

commands, and is the Command File used by the Do Command 

Line VI. The source line specifies which circuit netlist file to load 

and to apply the analysis to. The analysis results are saved to the file 

specified in the write-and-destroy-iplot line. 

 Save the changes and close Notepad®. 

 

LabVIEW 

6. Start LabVIEW. 

 Launch LabVIEW. 

 Confirm that you have the LabVIEW Multisim API Toolkit VIs, 

they should be located under the Connectivity » Multisim 

subpalette. 

 
Note If you do not see the toolkit VIs, you may need to install the LabVIEW Multisim API Toolkit. It can 

be installed from the Multisim installer. Select the toolkit from the features to install tree. LabVIEW 

2013 or higher needs to be installed for the Multisim installer to enable the toolkit feature. 
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7. Build the VI. 

 Select Help » NI Multisim API Toolkit Help. 

 In the Help file, browse to Programming Guide » Programming 

Flowcharts » Flowchart for SPICE Netlist.  

 Use the flowchart as a reference to build the LabVIEW VI that will 

execute the SPICE netlist.  

 
Tip If you would rather use a pre-built VI, open and run the SPICE Command Line.vi included with 

this tutorial. It has more code than the example shown here but the logic is similar. 

This is the minimum code you need to build: 

 

The LabVIEW Multisim API Toolkit VIs are located in the functions 

palette. Right-click the block diagram and select the Connectivity » 

Multisim subpalette. Use the following table if you are having 

trouble finding the VIs in the subpalettes.  

VI Subpalette 

Connect Connection 

New File File 

Command Line Simulation 

Wait for Next Output Simulation 

Last Error Message Error & Utility 

Disconnect Connection 

Two subVIs are included with this tutorial, sub Create Local Paths 

VI and sub Data Parser VI, which are custom made, you can create 

your own if you wish, or for convenience use these subVIs provided. 

 sub Create Local Paths—this VI takes the caller VI local 

path and creates four file paths in the same directory, one 

path each for the log file, command file, SPICE netlist file 

and the raw data results file. 
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 sub Raw Data Parser—this VI finds the raw data file and 

parses it into a LabVIEW XY Graph display. It is custom 

made for this particular transient analysis with two variables. 

 
Tip Review the sub Raw Data Parser VI in particular, as it provides a reference on how to properly parse the 

raw data results file. 

Since you have not run the VI yet, you do not have the raw data 

results file to reference. You can use the RawData.tmp file 

included with this tutorial to see how Multisim formats the results in 

the text file. You may open this file in Notepad® or any text editor 

program. The sub Raw Data Parser VI will be easier to understand. 

The Wait for Next Output VI can be replaced by more preferred 

architectures, like event-based architectures. It is the easiest to 

include in a small program like this example VI. 

Error-checking is not required, but is highly recommended. The Last 

Error Message VI helps to troubleshoot and manage errors. 

 Once you have finished reviewing the pre-built example VI, or have 

finished creating your own VI, proceed to the next step. 

8. Run the VI. 

 Click Run to start the VI. 

 
Note If this is the first time you launch Multisim, this VI may take anywhere from 30 to seconds to 1 

minute to run. It takes the same time as  starting Multisim manually. 

 Once the VI has completed, the XY Graph control will be populated 

with the analysis data. It will look similar to the following XY graph 

screen capture. 
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 Caution Every time you run the Command Line VI, it will overwrite the files specified in the file paths if 

they already exist. To keep the files intact after each program iteration, add the program logic 

necessary to supply new file paths. 

 

Summary 
This tutorial explained the simplest process to get a text-based SPICE netlist and 

a SPICE nutmeg commands file to simulate from LabVIEW. This is particularly 

important when you want to have advanced access to the Multisim simulation 

engine for analyses. 

Your LabVIEW programs will most likely be far more complex than the one 

presented here. However, the purpose of the tutorial is to show the simplest and 

most basic way to connect to the Multisim engine and simulate the SPICE 

commands. 

If you want to review the pre-built example, open the SPICE Command Line VI 

located in the same folder as this tutorial. Remember that the two subVIs 

referenced in this tutorial were custom-made for this particular analysis. 

 

 


