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This tutorial will introduce you to many of the tools, workbenches, and methods you will 
use in your daily work. The part you’ll create is an aluminum casting. It should take less 
than two hours to complete. Many aspects of basic design work are touched on in this 
exercise, but no single tutorial can show-case all of the capabilities of Alibre. Please feel 
free to contact me with any corrections, or suggestions on ways to improve the material.  
 
The drawing below will give you all the information required to create the Inlet Manifold 
and serve as a reference in the part design process. 
 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



We need to set a few basic parameters in Alibre before we start the actual design process. 
In the Alibre Design Main panel, click on File>New>Part.  
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The New Part window opens.  
 



  
 
 
 
 
 
 
Under the File menu tab, select 
Properties. 
 
 
 
 
 
 
 
 
 
 
 
The Design Properties panel will open. Click on the ‘Units’ tab and select Millimeters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Under the ‘Material’ tab scroll down in 
the selection window an click on 
‘Aluminum – cast – hammered’. This 
will set the material properties for our 
model, allowing us to determine the 
mass, and volume of the part as well as 
the center of mass, surface area, and 
moments of inertia.  
 
 
 
 
 
 
 
 
 
Under the Apply Options tab, check the radio button for ‘The Current Document’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 



 
Go back to the main panel toolbar and 
locate ‘Tools’. Under the ‘Tools’ menu 
tab, select ‘Options’. 
 
 
 
 
 
 
 
 
 
 
 
 
The ‘Options’ panel will open. Under the ‘Grid’ tab change the spacing settings to 1mm 
for X, Y, and Z. Make sure the ‘Display grid’, and ‘Snap to grid’ boxes are checked. 
Click OK to return to the New Part window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
  
 
 
 
 
 
  
        In the New Part window under the  
 File menu tab, select ‘Save’. Select a 

location to save the file, either in the 
Windows File System or in your local 
repository. Give the part a logical 
name, and click OK. 

 
 
 
 

 
 



 
 
Click on the XY plane in the Design Explorer panel, or 
the XY plane in the Part workspace and then click the  
‘Activate 
2D Sketch’ 
icon. Now 
you’re in 
'Sketch’ 
mode. 

 
 
 
 
 
 
 
 
 
  
We’ll start our design by drawing a circle, dimensioning it, and positioning it as shown 
below. 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Next, we’ll sketch an arc using the Circular Arc – Center, Start, End command, with a 
radius of 80 mm and position it as shown. 
 

Make the arc large enough to extend past the circle and the X-axis, with an angle value of 
approximately 30-40 degrees. 
  
Dimensioning and constraining sketches is one of the most important aspects of good 
design work. You’ll notice in the lower right hand corner of the Alibre main panel screen 

a running script labeled DOF (Degrees of Freedom). Reducing 
the DOF’s to zero, through dimensional or geometric constraints, 
although not always necessary is good design practice. You can 

produce parts and features with sketches that have unresolved DOF’s, but my advice is to 
reduce the DOF’s to zero through use of dimensions or geometric constraints to insure 
the stability of the model data. If you find that you can’t reduce the DOF’s by manual 
insertion of the dimensions and constraints, use the Auto Dimension command under the 
Sketch menu tab to complete the task.  



Next, under the Sketch menu tab select Repeat>Circular. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



When the ‘Circular Repeat’ panel opens, click on the circular arc you created and click 
on the origin point as the Center, select 2 for the number of copies and an angle value of 
90°. Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 



Draw two lines as shown, one vertical and one horizontal, both long enough to cross the 
two arcs. Your sketch should now look like this. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
You’ll need to trim 
the arcs and lines 
using the ‘Trim 
Figure’ command.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Continue trimming the sketch until it looks like this.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Although the best design practice is to add fillets and holes as dress-up features as late in 
the design process as possible, we’ll add both to our base sketch at this point in order to 
simplify the part creation process. Add a circle of 5 mm diameter and position it 
concentric to the 5 mm radius circle with a concentric constraint as shown. 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Next, add the fillets using the 2D Fillet command.   
  

Your sketch should look like this when finished 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 Next click on the Extrude Boss icon and extrude the sketch to a depth of 10 mm in the 
positive Z direction as shown.  

 
 
 
 
 
 
 
 



Your part should now look like this. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This is the basic building block of the base part. 

 
 
 
Now we need to duplicate this 
feature three more times in 
order to complete the base. 
Under the ‘Feature’ tab select 
‘Pattern>Circular. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 



When the Circular Pattern panel opens, click on the extrusion you just created in either 
the Part workspace or in the Design Explorer panel. Select the Z-axis from the Part 
workspace or Design Explorer panel; enter 4 for the number of copies, and an angle value 
of 90°. Click the Change direction box if necessary and then click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
  
 
 
 
 
 
 
 
 
 
 
 
 



Your part should now look like this. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Another approach open to us is to rotate the sketch entities as shown on the next page, by 
using the Sketch>Repeat>Circular command, and then extrude this as one solid part. In 
using a quarter of the base design to generate our extrusion, and then rotating the feature 
makes future revisions much more efficient. Changes made to the base part will 
propagate in the copies when the part is regenerated. It’s also easier to constrain the 
quarter part sketch, and reduce its DOF’s to zero than it is for the more complex sketch.  
  
It’s a good idea to determine what elements of your design might lend themselves to   
symmetry or patterning operations. The simpler the design history is, the easier it will be 
to change or revise the part in the future. 
 
   
 
 
 
 
 
 
 
 
 



How we might have used 
the Sketch>Repeat>Circular 
command to generate the 
base sketch. 
 
Using sketch patterns in lieu 
of feature patterns can be 
useful in many cases, but 
both options should be 
considered on a case-by-
case basis with an eye 
towards future revisions. 
 
 
 

 
 
 
 

 
 
 
 
 
 
 
   
 
  
 
 
 
 
 
 
 
 
 
 
 
  
  
 
 
 
 



The next step in the design process is to create the main cylindrical boss. Select the ZX 
plane in either the Part workspace or the Design Explorer panel and then click on the 
Activate 2D Sketch icon. Create the sketch below, dimensioning, and constraining it as 
shown.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Click on the Revolve Boss icon, and fill in the information as shown, using the ‘Z’ axis 
as your axis of revolution. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Click OK. 
 
 
 
 

Your part should now look like this. 
 
 
 
 
 
 
 
 



Now we’ll create one of the stiffener ribs and use the ‘Pattern>Circular’ command to 
create the other three. Select the XZ plane and click the ‘Activate 2D Sketch’ icon to 
enter sketch mode. Create the sketch shown at the right. Make sure your sketch 
‘penetrates’ the cylinder envelope. This will avoid any problems you might otherwise 
encounter because of the vertical rib element not being coincident with the profile of the 
cylinder after it’s extruded. 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Click the ‘Extrude Boss’ icon and enter the information shown, set ‘Type’ to ‘Mid 
Plane’, and ‘Depth’ to 3 mm. Click OK. The reason for using the ‘Mid Plane’ modifier 
should be obvious. It maintains the symmetry of the rib around the XZ plane and also 
ensures a good interface between the rib and the cylinder. 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
  
Under the ‘Features’ 
menu on the toolbar, 
select 
‘Pattern>Circular. 
Click’ on the ‘Fin’ 
feature to select it as 
the feature to pattern. 
Select the Z-axis as the 
center. Enter 4 for the 
number of copies and 
an angle value of 90°. 
Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
Your part should now look like 
this. 
 
 
 
 
 
 



The next step is to create the angled cylindrical boss and the smaller boss attached to it. 
Select the XZ plane and click on the ‘Activate 2D Sketch’ icon to enter sketch mode. 
Create, dimension, and constrain the sketch shown below.   
 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

   
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
Click the ‘Revolve 
Boss’ icon and enter 
the information 
shown.  Use the 
dimensioned 18° 
sketch line as the axis 
of revolution. Click 
OK. 
 
 
 
 
 
 
 
 
 

 

 

 
 
 
Your part should now look like this.   
 
 
 
 
 
 
 
 
 
  
 



To create the small cylindrical boss on the side of the larger one, we’ll first need to insert 
a plane tangent to the larger cylinder. Under the ‘Insert’ menu tab, select ‘Plane’. 

 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The ‘Insert Plane’ panel will open. Click on the ZX plane and then click on the surface of 
the larger cylinder. Click ‘Reverse’ if necessary and then click OK. You now have the 
geometric anchor for the small cylinder 
 
 
 
 
 
 
 



Click on the new plane and 
click on the ‘Activate 2D 
Sketch’ icon to enter sketch 
mode. Create the sketch shown 
at the left using a reference 
line if necessary for the 10 mm 
dimension.  
Hint : Use Project to Sketch to 
create the front cylinder face 
reference line and two points. 
 
 
 
  
 
 

 
 
 
 
 
 
 
 
 
 
 
 
Click on the ‘Extrude 
Boss’ icon and enter the 
values shown, then click 
OK. 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
Your part should now 
look like this. 
 
 
 
 
 
 
 
 
 
 
  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now we need to add the 
holes to our part. Click on 
the top face of the large 
cylindrical boss as shown 
in the figure to the left.  
Click on the ‘Hole’ icon. 

 
 
 
 

 



The ‘Insert Hole’ panel will open. Select the options and fill in the information shown, 
then click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 



It might be necessary to locate the hole after it’s created. To do this, click on the ‘Hole’ 
‘Sketch’ in the Design Explorer panel, right click and select ‘Edit’. 

 
Apply a concentric constraint between the center 
point of the hole and the center point of the boss. 
 
 

 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Your part should now look like 
this. 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 



  
 

 

 
Repeat the steps you used to create the 
hole in the large boss to create the hole in 
the medium boss as shown below. Use a 
large enough offset (Limiting geometry 
offset)so your extruded cut extends past 
the inside surface of the large hole. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
This is how the part should look after 
the cut is complete. 
 
 

 
Use the same process for the hole in the small 
boss. 
 
 

 
 
 
 
 
 
 
 
 
 
Your part should now look 
like this. 
 
 
 
 
 
 
 



The last thing you’ll 
need to do to finish 
the part, is to add the 
fillets and top holes. 
Fillets can be added in 
groups. This is best 
accomplished if the 
fillets do not touch 
one another. 
Something else to 
keep in mind, is the 
fillets should be added 
in a way that helps to 
support the other 
fillets you create. Add 
the fillets in the order 
shown in the 
following pictures. 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Now it’s time to add the four drilled and tapped holes in the top flange of the casting. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click on the top flange and then click on the ‘Hole’ icon. Insert one machined hole in the 
top flange with the information shown above. 
  
 
 
 
 
 
 
 
 
 



Then use the ‘Circular Pattern’ command to create the 3 other holes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Congratulations you’ve completed the Inlet Manifold Tutorial and hopefully your part 
looks like the one below. If it doesn’t, the model file is available at 
www.carrinfo.com/InletMaifold.stp. It’s an Alibre STEP file and contains the complete 
history tree for the model. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
As an added feature of this tutorial, you’ll remember at the beginning of the exercise we 
assigned a material to our part (Aluminum cast-hammered) .To see another powerful 
feature of the Alibre Design application go to the ‘Tools’ tab on the top menu bar and 
select ‘Physical Properties’. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.carrinfo.com/InletMaifold.stp


The ‘Physical Properties’ panel will open. Select the level of accuracy you want to use 
and then click ‘Calculate’ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



The results will be displayed in the panel. Try doing that with a surface model! 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This ends the ‘Inlet Manifold’ tutorial.  
 
Look for more tutorials in the future, and a complete training manual covering Alibre part 
design, drawing and BOM creation, assembly design, sheet metal parts, and how to drive 
designs through Excel spread sheet design tables.  
 
 


