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This tutorial will introduce you to many of the tools, workbenches, and methods you will 
use in your daily work. The part you’ll create is an aluminum casting. It should take less 
than two hours to complete. Many aspects of basic design work are touched on in this 
exercise, but no single tutorial can showcase all of the capabilities of Alibre. Please feel 
free to contact me with any corrections, or suggestions on ways to improve the material.  
 
The drawing below will give you all the information required to create the Motor Mount 
and serve as a reference in the part design process. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
We need to set a few basic parameters in Alibre before we start the actual design process. 
In the Alibre Design Main panel, click on File>New>Part.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The New Part window opens.  
 



 
 
 
 
 
 
 
Under the File menu tab, select 
Properties. 
 
 
 
 
 
 
 
 
 
 
 
The Design Properties panel will open. Click on the ‘Units’ tab and select Millimeters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Under the ‘Material’ tab, scroll down in 
the selection window and click on 
‘Aluminum – cast – hammered’. This 
will set the material properties for our 
model, allowing us to determine the 
mass, and volume of the part as well as 
the center of mass, surface area, and 
moments of inertia.  
 
 
 
 
 
 
 
 
 
Under the Apply Options tab, check the radio button for ‘The Current Document’. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 



 
Go back to the main panel toolbar and 
locate ‘Tools’. Under the ‘Tools’ menu 
tab, select ‘Options’. 
 
 
 
 
 
 
 
 
 
 
 
 
The ‘Options’ panel will open. Under the ‘Grid’ tab change the spacing settings to 1mm 
for X, Y, and Z. Make sure the ‘Display grid’, and ‘Snap to grid’ boxes are checked. 
Click OK to return to the New Part window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
  
 
 
 
 
 
  
        In the New Part window under the  
 File menu tab, select ‘Save’. Select a 

location to save the file, either in the 
Windows File System or in your local 
repository. Give the part a logical 
name, and click OK. 

 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
Click on the XY plane 
in the Design Explorer 
panel, or the XY plane 
in the Part workspace 
and then click the  
‘Activate 2D Sketch’ 
icon. Now you’re in 'Sketch’ mode. 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
We’ll start our design by drawing 
a sketch similar to the one at the 
left. The picture has been rotated 
90 counter clockwise, which 
places the X-axis in the vertical 
orientation. The sketch only needs 
to be a close approximation to 
what we want the final part to 
look like. In most of the following 
pictures, the sketch grid has been 
turned off, simply for the sake of 
clarity. You should leave your 
grid turned on to aid you in your 
sketch work. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Now apply the five dimensions 
shown at the right. These 
dimensions will ‘lock in’ the 
overall shape of out part, and 
establish an important set of 
relationships. 
 
Dimensioning and constraining 
sketches is one of the most 
important aspects of good 
design work. You’ll notice in 
the lower right hand corner of 
the Alibre main panel screen a 
running script labeled DOF 
(Degrees of Freedom). R
the DOF’s to zero, through 
dimensional or geometri
constraints, although not always 
necessary, is good design 
practice. You can produce
and features with sketches that 
have unresolved DOF’s, but m
advice is to reduce the DOF’
zero through use of dimen
or geometric constraints to 
insure the stability of the model
data. If you find that you can’t 
reduce the DOF’s by manual 
insertion of the dimensions and 
constraints, use the Aut
Dimension command und
Sketch menu tab to complete the
task. In this case, we have a lot 
more dimensioning work to 
complete, so ignore this for th
present. 
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Select the 2D Fillet 
command and Insert 
two fillets as shown 
in the pictures at the 
right.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Dimension them as shown. When complete your sketch should look like the picture at the 
right, and the one below. 
 

 
Add the 320mm and 55mm 
horizontal linear dimensions before 
adding the 56mm and 60mm vertical 
dimensions. Adding the dimensions 
in this order further constrains the 
overall shape of the sketch. Try it 
the other way to see what the results 
are. 
 

 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
Insert the two 10mm 
diameter holes as show in 
the pictures. You could 
insert these holes in the 
finished model as a ‘hole 
feature’ using the ‘Hole’ 
command. This is 
considered a best practice 
rule when working with 
solid features. 
Exceptions to this rule 
include inserting holes, 
fillets, or chamfers in the 
sketch when such features 
constitute a basic, 
unchanging feature of the 
part, i.e. not a dress-up 
feature. In this case, we’ll 
treat all holes and fillets 
as basic features of the 
casting. 
 
 
 
 
 
 



 
 
 
 
 
 
 
 
 
 
 
Any sketch created within the 
boundaries of the outer sketch 
will propagate as a cutout when 
the sketch is extruded. To create 
the rectangular cutout in the 
motor mount, sketch and 
dimension the shape shown at the 
left.  
 
To make the task a little easier, 
use the Rectangle by Two 
Corners tool to create the initial 
sketch, then add the fillets and 
dimension it. 

 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 

 

To create the next two cutouts we’ll use the ‘Offset’ 
command to create the two angle lines and the bottom 
horizontal line.   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Now add and dimension the vertical line shown in the sketch below. The 274mm 
dimension is taken from the far left vertical sketch line. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

 
Now use the Extend Figure and Trim Figure 
commands to clean up your sketch. 
 
 
 
 
 

 
 
 
 
 
 
 



 
 
When finished the results 
should look like this, 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Add the angle line shown at the 
left.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 



 
Dimension the line as shown. 

 
 
 
 
 
 
 
 
 

 
 

 

 
 
 
 
 
 
 

 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Trim the lines until you have the shape shown below. 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Insert two angled lines as shown. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Extend and Trim the lines, and insert the parallel constraints as shown. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Next, insert the seven, 5mm corner fillets shown. 
 
 
 
 
 
  
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

It might be necessary to 
add a Tangent constraint 
between the line and arc 
shown to bring the cutout 
figures into correct 
alignment. To do this, 
open the constraint tool, 
select Tangent Constraint, 
click on it to make it 
active, and then click on 
the line and then the arc. 

 



 
 

Your sketch should now look like this. (The dimensions and constraints have been hidden 
to clarify the sketch.) 

 
 
 
 
 
 
 
 

Now add the 25mm fillets. Again, we could 
create these as a dress up features after we 
extrude the basic motor mount shape, but 
for this case, we can consider them basic 
features of the part, not subject to change, 
so we’ll include them as part of the sketch. 
 
 
 
 
 
 



 
It’s now time to extrude our sketch and create the basic, motor mount shape. It would be 
a good idea at this point to use the Sketch Analyze tool to check your sketch for problems 
before you extrude it. 
 
 
Select Extrude Boss. 
 
 
 
 
 
 

Select the sketch if it is not already selected, then select To Depth as Type, and enter 
26mm as the Depth, then click OK. 
 
 
 



Your part should now look like this.  
 
 
Change the view orientation                                                           until the motor mount is 
in the position shown below. 
 
 
 

 



Select the face of the motor mount, 

 
 then select Activate 2D Sketch. 
 
 
 
Now we need to add the two 18mm deep pockets. We’ll add both pockets at the same 
time. Create and dimension the sketches shown in the following two pictures. Use the 
Rectangle by Two Corners tool for the left hand pocket. 



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Click on Extrude Cut.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Select the newly created sketch if it is not already selected, select To Depth as the Type, 
insert 18mm as the Depth, and click OK. (Part rotated to clarify direction of depth cut.) 
 

 
 
 
 
 
 
 
 



 
 
Your part should now look like this. 
 
Now we need to add the two sets of holes. Select the bottom face of the first pocket. then 
select Activate 2D Sketch.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Click on the Hole icon. 
 
 
 
 
 
 
 

 
 
The Insert Hole Panel opens. Set the diameter to 5mm, the Type as Simple, the Depth 
condition as Through All, and then click OK. 

 
 
The hole appears in the pocket. We now need to 
to properly locate the hole. In the Design 
Explorer panel select the sketch associated to the 
hole, right click, and select Edit. 
 
 
 



 
Locate the Hole center per the 
following dimensions. When 
finished, click the Select arrow 
to end the Edit process. 

 

The hole is now located in the 
correct position. 
 
 
 
 
Per the drawing, we need to locate the next hole 7mm from the opposite inside wall of the 
pocket, and 18mm from the bottom edge. In this part of the exercise , we’ll use the 
Feature >Pattern>Linear command to locate the second hole instead. 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



The Linear Pattern panel will open. Select the hole as the Feature to pattern. You can do 
this from the Design Explorer panel or by selecting it directly from the model. Make sure 
Pattern Geometry is selected, click on the X axis either in the model window or select it 
from the Design Explorer, enter 36mm as the Spacing, and select copies as 2. A hole 
outline will appear. If necessary click Change direction, then click OK. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 



 
 
 
 
 
 
 
 
 
The new hole appears. 
 
 
 
 
 
 
 
 
 

Repeat this process for the second set of holes. When complete your part should look like 
this.  
  
 
 
 
 
 
 
 
 
 



The final step in the design process is to create a cut on one face of the motor mount.  
Select the flat face shown as your sketch base, and the select Activate 2D Sketch. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Create and dimension the sketch shown below. Constrain the point indicated to the line 
representing the front edge of the motor mount with a Coincidence constraint. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Select Extrude Cut.  
 
 
 
 
 
 
 

In the Extrude Cut panel, select the sketch if it’s not already selected, select Through All 
as Type, and then click OK.  
 
 
 
 
 



 
 

Your part should now look like this. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
Because we specified the type of 
material from which the motor mount 
is fabricated, we can retrieve specific 
physical properties from our finished 
model. Click on Tools>Physical 
Properties. 
 
 
 
 
In the Physical Properties Panel, 
select the level of Accuracy desired, 
and then click Calculate. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
The Physical Properties are returned.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This concludes the Motor Mount Tutorial. I hope you’ve enjoyed creating the part, and 
hope you learned a few things along the way. Look for other tutorials in the future.  


